数值风云

OpenFOAM230安装问题

有了230的安装包,参考的博客是下面给的两种。
image
OpenFOAM安装详解_苏军伟_新浪博客 (sina.com.cn)
OpenFOAM 安装_CFD界_新浪博客 (sina.com.cn)
在OpenFOAM-2.3.0下./Allwmake编译出现错误:


认为是gcc版本太高得问题,但是切换到:

编译还是出错了= =、

请问大家安装一些老版本的OpenFOAM是怎么装的呢,我记着之前我装OpenFOAM-7按照上面那两个博客是没问题的啊- -