数值风云

Foam-extend 4.0安装问题

最近在学习流固耦合,需要用到foam-extend,但是在安装过程中遇到了问题。我是在Ubuntu 18.04上进行编译安装的,装的foam-extend 4.0


错误见这个图,没太明白这个’Huge’什么意思。有没有大神可以指导?或者推荐其他的安装方法?:weary::weary::weary:

之前在CentOS7上装成功过。
可以参考: Installation/Linux/foam-extend-4.0/Ubuntu - OpenFOAMWiki
ThirdParty里面Allwmake可以细分为很多个stage,哪个stage失败就可以看看对应的脚本文件内容,就能定位到是哪个包出问题了,比如网络不行导致包下载失败,就可以手动下载放到对应的目录中。

谢谢谢谢,我再试着根据提示找找错误:grin:

安装问题解决了, 4.0一直有问题,所以我改装4.1了,而且发现官网给教程所提供安装步骤不全,所以又写了一个,方便自己以后看,FOAM-extend 4.1 安装指南 - 知乎
这个是链接,希望能帮到有需要的朋友。